Capa para posts com Tabelas

Comandos Portugol vs Fluxograma

Tabela que mostra uma comparação entre os comandos do Portugol e sua representação em fluxograma, de forma a ajudar o aluno no aprendizado de algoritmos.

O Senhor dos Algoritmos

Essa tabela pode ser encontrada para
download no e-book O Senhor dos Algoritmos.

ComandoExemplo em PortugolExemplo em FluxogramaObservações
Início do algoritmoinicioInício do algoritmo

Criação de variáveisvar
    idade, dias: inteiro
não temNas minhas aulas eu não vejo necessidade dessa informação no fluxograma, uma vez que ele indica o fluxo de execução do algoritmo, ou seja, tem mais a ver com lógica de programação do que com o código em si.
Entrada de dadosleia(idade)Entrada de dados
Para lembrar, costumo comparar o símbolo com um teclado.
Processamentodias <- 365 * idadeProcessamento
Saída de dadosescreva(dias)Saída de dados
Para lembrar, costumo comparar o símbolo com um monitor (antigo), visto de lado.
Fim do algoritmofimalgoritmoFim do algoritmo
Chamada de procedimento / funçãonome(valor, ...)Chamada de procedimento / função
Estrutura "se-então"se idade < 18 entao
    ...
fimse
Estrutura "se-então"
Estrutura "se-então-senão"se idade < 18 entao
    ...
senao
    ...
fimse
Estrutura "se-então-senão"
Estrutura "escolha-caso"escolha dia
    caso 1
        ...
    caso 2
        ...
    caso 3
        ...
    outrocaso
        ...
fimescolha
Estrutura "escolha-caso"
Alguns autores utilizam apenas um losango, com vários fluxos saindo dele, cada um com um dos casos previstos.
Estrutura "enquanto"i <- 1
enquanto i <= 10 faca
    ...
    i <- i + 2
fimenquanto
Estrutura "enquanto"
Notar que os símbolos em cinza não fazem parte da estrutura "enquanto"; eles estão lá para comparação com a estrutura "para".
Estrutura "repita-até"repita
    ...
ate opcao = "sair"
Estrutura "repita-até"
Estrutura "faca-enquanto"faca
    ...
enquanto opcao <> "sair"
Estrutura "faca-enquanto"
Esse comando não existe no Portugol do Visualg. Mas, existe na maioria das linguagens como C#, e Java. O que muda é que ele repete enquanto a condição for verdadeira.
Estrutura "para"para i de 1 ate 10 passo 2 faca
    ...
fimpara
Estrutura "para"
Alguns autores utilizam apenas um hexágono alongado ao invés do losango; dentro dele, colocam o valor inicial, o valor final e o passo.

3 ideias sobre “Comandos Portugol vs Fluxograma

    1. Ramon Chiara Autor do post

      Oi, Mauricio!

      Obrigado pelo feedback!

      Sobre a chamada de procedimentos, o símbolo indica a execução de outro algoritmo.
      Imagine um sistema onde há um menu de comandos.
      Para não ficar um mega fluxograma, podemos fazer um indicando a lógica do menu principal.
      E, para cada opção, chamar um algoritmo indicado num fluxograma desenhado à parte.

      Espero que tenha conseguido explicar… 🙂

      Abraços

      Responder

Se você gostou do post, tem alguma dúvida ou encontrou algum erro, por favor, deixe uma mensagem! Seu feedback é muito importante!