Capa para posts com Tabelas

Comandos Portugol vs Java

Tabela que mostra uma comparação entre os comandos do Portugol (Visualg) e do Java de forma a ajudar o aluno na transição entre uma linguagem e outra.

O Senhor dos Algoritmos

Essa tabela pode ser encontrada para
download no e-book O Senhor dos Algoritmos.

ComandoPortugolJava
Variável tipo inteiroi: inteirobyte i;
short i;
int i;
long i;
Variável tipo reald: realfloat d;
double d;
Variável tipo lógicob: logicoboolean b;
Variável tipo textos: caracterechar c;
String s;
Variável tipo vetorv: vetor[linha1..linhaN] de tipotipo[] v = new tipo[linhas];
Variável tipo matrizm: vetor[linha1..linhaN, coluna1..colunaN] de tipotipo[][] m = new tipo[linhas][colunas];
Exemplos de literais (valores) do tipo inteiro33 // int
3L // long
Exemplos de literais (valores) do tipo real3.143.14F // float
3.14 // double
Exemplos de literais (valores) do tipo lógicoFALSO
VERDADEIRO
false
true
Exemplos de literais (valores) do tipo texto"texto entre aspas"'C' // char
"texto entre aspas" // string
Ler valor tipo inteiroleia(i)i = Byte.parseByte(console.nextLine());
i = Short.parseShort(console.nextLine());
i = Integer.parseInt(console.nextLine());
i = Long.parseLong(console.nextLine());
Leia a observação no final da tabela!
Ler valor tipo realleia(d)d = Float.parseFloat(console.nextLine());
d = Double.parseDouble(console.nextLine());
Leia a observação no final da tabela!
Ler valor tipo lógicoleia(b)b = Boolean.parseBoolean(console.nextLine());
Leia a observação no final da tabela!
Ler valor tipo textoleia(s)s = console.nextLine();
Leia a observação no final da tabela!
Escreverescreva(...)System.out.print(...);
Escrever, pulando linhaescreval(...)System.out.println(...);
Escrever com parâmetrosescreva(..., a, ..., b, ...)System.out.printf("...%t...%t...", a, b, …);
Para saber o que colocar no lugar do t, consulte a documentação do Java.
Escrever com parâmetros, pulando linhaescreval(..., a, ..., b, ...)System.out.printf("...%t...%t...\n", a, b, …);
Para saber o que colocar no lugar do t, consulte a documentação do Java.
Limpar telalimpatela(não tem comando específico)
Operação de atribuição (recebe)a <- ba = b;
Operação de adiçãoa + ba + b
Operação de subtraçãoa - ba - b
Operação de multiplicaçãoa * ba * b
Operação de divisãoa / ba / b
Operação de divisão inteiraa \ ba / b
(sendo a e b inteiros)
Operação de resto da divisãoa % b
a mod b
a % b
Operação de potenciaçãoa ^ bMath.pow(a, b)
Operação de raiz quadradaRaizQ(a)Math.sqrt(a)
Operação de concatenação"texto" + "texto"
"texto" + a
a + "texto"
"texto" + "texto"
"texto" + a
a + "texto"
Operação de acesso a um valor do vetorv[índice da linha]v[índice da linha]
(índice começa em 0 e termina em tamanho - 1)
Operação de acesso a um valor da matrizm[índice da linha, índice da coluna]m[índice da linha][índice da coluna]
(índices começam em 0 e terminam em tamanho - 1)
Operação de acesso ao tamanho do vetor(não tem operador específico)v.length
Operação de acesso ao tamanho da matriz(não tem operador específico)(não tem operador específico)
Operação de acesso à quantidade de dimensões da matriz(não tem operador específico)(não tem operador específico)
Operação de acesso ao tamanho das dimensões da matriz(não tem operador específico)(não tem operador específico)
Operação menora < ba < b
Operação menor ou iguala <= ba <= b
Operação maiora > ba > b
Operação maior ou iguala >= ba >= b
Operação iguala = ba == b
Operação diferentea <> ba != b
Operação ea e ba && b
Operação oua ou ba || b
Operação ou-exclusivoa xou b(não tem operador específico)
Operação de negaçãonao a!a
Operação bit-a-bit e(não tem operador específico)a & b
Operação bit-a-bit ou(não tem operador específico)a | b
Operação bit-a-bit ou-exclusivo(não tem operador específico)a ^ b
Operação bit-a-bit de negação(não tem operador específico)~a
Operação de incremento(não tem operador específico,
mas pode ser feito com a <- a + 1)
a++
++a
Operação de decremento(não tem operador específico,
mas pode ser feito com a <- a - 1)
a--
--a
Operação com atribuição(não tem operador específico)a op= b
(é o mesmo que a = a op b)
Comando se-entãose condição entao
    ...
fimse
if (condição) {
    ...
}
Comando se-então-senãose condição entao
    ...
senao
    ...
fimse
if (condição) {
    ...
} else {
    ...
}
Comando se-então-senão encadeadosse condição1 entao
    ...
senao
    se condição2 entao
        ...
    senao
        ...
    fimse
fimse
if (condição1) {
    ...
} else {
    if (condição2) {
        ...
    } else {
        ...
    }
}
Comando se-então-senão encadeados
(versão melhorada do Java)
se condição1 entao
    ...
senao
    se condição2 entao
        ...
    senao
        ...
    fimse
fimse
if (condição1) {
    ...
} else if (condição2) {
    ...

} else {
    ...

}
Comando escolha-casoescolha variável
    caso valor1
        ...

    caso valor2, valor3

        ...

    outrocaso
        ...

fimescolha
switch (variável) {
    case valor1:
        ...
        break;
    case valor2:
    case valor3:
        ...
        break;
    default:
        ...
        break;
}
Comando enquanto-façaenquanto condição faca
    ...
fimenquanto
while (condição) {
    ...
}
Comando parapara variável de valor1 ate valorN passo P faca
    ...
fimpara
for (variável = valor1; variável <= valorN; variável += P) {
    ...
}
Comando repita-até
(termina com condição verdadeira)
repita
    ...
ate condição
(não tem comando específico)
Comando faça-enquanto
(termina com condição falsa)
(não tem comando específico)do {
    ...
} while (condição);
Comando de interrupçãointerrompabreak;
Comando de próxima iteração(não tem comando específico)continue;
Criar procedimentoprocedimento nome(parâmetro: tipo; ...)
var
    ...
inicio
    ...
fimprocedimento
static void nome(tipo parâmetro, ...) {



    ...
}
Criar funçãofuncao nome(parâmetro: tipo; ...): tipo
var
    ...
inicio
    ...
retorne valor
fimfuncao
static tipo nome(tipo parâmetro, ...) {



    ...
    return valor;
}
Chamar procedimentonome(valor, ...)nome(valor, ...);
Chamar funçãoa <- nome(valor, ...)a = nome(valor, ...);
Para usar o objeto “console”, devemos, antes, criá-lo:

import java.util.Scanner;

public class Program {
    public static void main(String[] args) {
        Scanner console = new Scanner(System.in);
        // a partir daqui, pode-se fazer leitura de dados usando o objeto console.
    }
}

4 ideias sobre “Comandos Portugol vs Java

  1. br0b

    Eu tava quem nem um doido a procura desse site!! Tinha visto esse post um dia mas não salvei porque achei que não ia precisar de novo, mas to precisando agora e passei o dia tentando achar! Obrigado! Vai me salvar mais uma vez!

    Responder

Se você gostou do post, tem alguma dúvida ou encontrou algum erro, por favor, deixe uma mensagem! Seu feedback é muito importante!